Digole
Digital Solutions
iDigole Buyer ProtectioniDigole Buyer
Protection
My shopping cart
0 Items:
Secure Checkout
Top Rated Plus
Visit Our Live Auctions
99.9% Customer's Satisfaction
 
Forum : Digole Serial Display :

 Search Forum.. 
 Creat New Topic   Reply 

Backlight command not working - 240x160 Mono LCD

Hi,

I recently purchased the 3" Mono LCD 240x160 from your  ebay store.

I am abble to write commands to display with UART, and can correctly draw shapes and write text etc.

But the backlight command not work. I tried BL100, BL50 etc. but backlight stays off. 

I've tried to power backlight manually, by connecting 3V3 and GND where the red and black wire from backlight are soldered, and this is working fine, so backlight HW is ok.

Can you help me how to control backlight using the MCU?

Thanks

RE:Backlight command not working - 240x160 Mono LCD

Could you please post your code here? the Backlight command usually affect after next command received.

RE:Backlight command not working - 240x160 Mono LCD

 example I tried:

1) Make connections, power on LCD, shows Digole logo

2) send "CL" clears screen 

3) send "BL100" nothing happens

4) send "TTHello World" shows "Hello World" on screen

After execute 4) and text seen on screen, the backlight still stays off

I tried different FW versions 3.9b, 4.0, 4.1b from your website but the issue still remains.

RE:Backlight command not working - 240x160 Mono LCD

"BL100" is not correct command, only one byte following to "BL" which indicate the brightness, try "BLd" to set up the brightness to 100% due to the ASCII value for "d" is 100.

Refer to the ASCII table: www.asciitable.com

RE:Backlight command not working - 240x160 Mono LCD

 Hello, I tried it in the correct way 'BLx' , giving 1 byte brightness value, for e.g. "BLd". Still doesn't seem to work, backlight stays off.

For other commands such as contrast e.g. 'CTx' works fine for me, only BLx gives problems.

Can you send me schematic of the backlight control circuitry. If this is PWM from PIC, I can try to probe switch node on PIC to see if there is any change.

RE:Backlight command not working - 240x160 Mono LCD

 If so, please check the on-board mosfet of FDN339, the most possible hardware problem could be the cold solder joint on this mosfet, the gate pin on the FDN339 was controlled by a PWM from the MCU.

RE:Backlight command not working - 240x160 Mono LCD

 Ok, thanks. Found bad soldering at FDN339. Backlight works correctly after fix

Copyright Digole Digital Solutions, 2008-2018. All rights reserved.
Powered by Victor Sun